What’s Vulnerable › Vulnerabilities
CVE-2018-5233
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-03-19 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in system/src/Grav/Common/Twig/Twig.php in Grav CMS before 1.3.0 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO to admin/tools.
Affected products
- getgrav Grav Cms: before 1.3.0 — fixed in 1.3.0
How to fix
Upgrade to a fixed version: getgrav Grav Cms 1.3.0. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2018/03/15/1
- https://sysdream.com/news/lab/2018-03-15-cve-2018-5233-grav-cms-admin-plugin-reflected-cross-site-scripting-xss-vulnerability/
- http://www.openwall.com/lists/oss-security/2018/03/15/1
- https://sysdream.com/news/lab/2018-03-15-cve-2018-5233-grav-cms-admin-plugin-reflected-cross-site-scripting-xss-vulnerability/
Get alerted when CVE-2018-5233 or the next vulnerability affects your stack