What’s Vulnerable › Vulnerabilities

CVE-2018-5249

Description

Cross-site scripting (XSS) vulnerability in Shaarli before 0.8.5 and 0.9.x before 0.9.3 allows remote attackers to inject arbitrary code via the login form's username field (aka the login parameter to the ban_canLogin function in index.php).

Affected products

How to fix

Upgrade to a fixed version: Shaarli 0.8.5, 0.9.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-5249 or the next vulnerability affects your stack