What’s Vulnerable › Vulnerabilities
CVE-2018-5316
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-09 · updated 2026-06-17
- Weakness: CWE-79
Description
The "SagePay Server Gateway for WooCommerce" plugin before 1.0.9 for WordPress has XSS via the includes/pages/redirect.php page parameter.
Affected products
- Patsatech Sagepay Server Gateway For Woocommerce: before 1.0.9 — fixed in 1.0.9
How to fix
Upgrade to a fixed version: Patsatech Sagepay Server Gateway For Woocommerce 1.0.9. Check the vendor advisory for mitigations.
References
- https://packetstormsecurity.com/files/145459/WordPress-Sagepay-Server-Gateway-For-WooCommerce-1.0.7-XSS.html
- https://wordpress.org/plugins/sagepay-server-gateway-for-woocommerce/#developers
- https://wordpress.org/support/topic/sagepay-server-gateway-for-woocommerce-1-0-7-cross-site-scripting/#post-9792337
- https://packetstormsecurity.com/files/145459/WordPress-Sagepay-Server-Gateway-For-WooCommerce-1.0.7-XSS.html
- https://wordpress.org/plugins/sagepay-server-gateway-for-woocommerce/#developers
- https://wordpress.org/support/topic/sagepay-server-gateway-for-woocommerce-1-0-7-cross-site-scripting/#post-9792337
Get alerted when CVE-2018-5316 or the next vulnerability affects your stack