What’s Vulnerable › Vulnerabilities
CVE-2018-5332
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-11 · updated 2026-06-17
- Weakness: CWE-787
Description
In the Linux kernel through 3.2, the rds_message_alloc_sgs() function does not validate a value that is used during DMA page allocation, leading to a heap-based out-of-bounds write (related to the rds_rdma_extra_size function in net/rds/rdma.c).
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0
- Linux kernel: before 3.2.99; from 3.3 before 3.16.54; from 3.17 before 3.18.92; from 3.19 before 4.1.50; from 4.2 before 4.4.112; from 4.5 before 4.9.77 — fixed in 3.16.54, 3.18.92, 3.2.99, 4.1.50, 4.14.44, 4.4.112
How to fix
Upgrade to a fixed version: Linux kernel 3.16.54, 3.18.92, 3.2.99, 4.1.50. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=c095508770aebf1b9218e77026e48345d719b17c
- http://www.securityfocus.com/bid/102507
- https://access.redhat.com/errata/RHSA-2018:0470
- https://git.kernel.org/pub/scm/linux/kernel/git/tip/tip.git/commit/?id=60daca9efbb3e4109ebc1f7069543e5573fc124e
- https://github.com/torvalds/linux/commit/c095508770aebf1b9218e77026e48345d719b17c
- https://lists.debian.org/debian-lts-announce/2018/05/msg00000.html
- https://usn.ubuntu.com/3617-1/
- https://usn.ubuntu.com/3617-2/
- https://usn.ubuntu.com/3617-3/
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
- https://usn.ubuntu.com/3620-1/
Get alerted when CVE-2018-5332 or the next vulnerability affects your stack