What’s Vulnerable › Vulnerabilities
CVE-2018-5380
- Severity: medium (CVSS 4.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 14.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-19 · updated 2026-06-17
- Weakness: CWE-125
Description
The Quagga BGP daemon (bgpd) prior to version 1.2.3 can overrun internal BGP code-to-string conversion tables used for debug by 1 pointer value, based on input.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- quagga: through 1.2.2
- Siemens Ruggedcom Rox Ii Firmware: before 2.13.0 — fixed in 2.13.0
How to fix
Upgrade to a fixed version: Siemens Ruggedcom Rox Ii Firmware 2.13.0. Check the vendor advisory for mitigations.
References
- http://savannah.nongnu.org/forum/forum.php?forum_id=9095
- http://www.kb.cert.org/vuls/id/940439
- https://cert-portal.siemens.com/productcert/pdf/ssa-451142.pdf
- https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-1550.txt
- https://lists.debian.org/debian-lts-announce/2018/02/msg00021.html
- https://security.gentoo.org/glsa/201804-17
- https://usn.ubuntu.com/3573-1/
- https://www.debian.org/security/2018/dsa-4115
- http://savannah.nongnu.org/forum/forum.php?forum_id=9095
- http://www.kb.cert.org/vuls/id/940439
- https://cert-portal.siemens.com/productcert/pdf/ssa-451142.pdf
- https://gogs.quagga.net/Quagga/quagga/src/master/doc/security/Quagga-2018-1550.txt
Get alerted when CVE-2018-5380 or the next vulnerability affects your stack