What’s Vulnerable › Vulnerabilities
CVE-2018-5387
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-24 · updated 2026-06-17
- Weakness: CWE-287
Description
Wizkunde SAMLBase may incorrectly utilize the results of XML DOM traversal and canonicalization APIs in such a way that an attacker may be able to manipulate the SAML data without invalidating the cryptographic signature, allowing the attack to potentially bypass authentication to SAML service providers.
Affected products
- Wizkunde SAMLBase: before 1.4.2 — fixed in 1.4.2
How to fix
Upgrade to a fixed version: Wizkunde SAMLBase 1.4.2. Check the vendor advisory for mitigations.
References
- https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations
- https://github.com/GoGentoOSS/SAMLBase/commit/482cdf8c090e0f1179073034ebcb609ac7c3f5b3
- https://github.com/GoGentoOSS/SAMLBase/issues/3
- https://www.kb.cert.org/vuls/id/475445
- https://duo.com/blog/duo-finds-saml-vulnerabilities-affecting-multiple-implementations
- https://github.com/GoGentoOSS/SAMLBase/commit/482cdf8c090e0f1179073034ebcb609ac7c3f5b3
- https://github.com/GoGentoOSS/SAMLBase/issues/3
- https://www.kb.cert.org/vuls/id/475445
Get alerted when CVE-2018-5387 or the next vulnerability affects your stack