What’s Vulnerable › Vulnerabilities

CVE-2018-5391: The Linux kernel, versions 3.9+, IP implementation is vulnerable to denial of service conditions with low rates of specially modified packets

Description

The Linux kernel, versions 3.9+, is vulnerable to a denial of service attack with low rates of specially modified packets targeting IP fragment re-assembly. An attacker may cause a denial of service condition by sending specially crafted IP fragments. Various vulnerabilities in IP fragmentation have been discovered and fixed over the years. The current vulnerability (CVE-2018-5391) became exploitable in the Linux kernel with the increase of the IP fragment reassembly queue size.

Affected products

How to fix

Upgrade to a fixed version: F5 BIG-IP APM 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; BIG-IP 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 Big-Ip Analytics 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 Networks, Inc. BIG-IP (AAM) 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; BIG-IP ASM 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 BIG-IP DNS 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 Big-Ip Edge Gateway 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 Big-Ip Fraud Protection Service 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 Big-Ip Global Traffic Manager 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 Big-Ip Link Controller 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 BIG-IP (LTM) 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1; F5 Networks, Inc. BIG-IP (PEM) 11.6.5.1, 12.1.5, 13.1.3, 14.0.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-5391 or the next vulnerability affects your stack