What’s Vulnerable › Vulnerabilities
CVE-2018-5410: Dokan file system driver contains a stack-based buffer overflow
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-07 · updated 2026-06-17
- Weakness: CWE-121
Description
Dokan, versions between 1.0.0.5000 and 1.2.0.1000, are vulnerable to a stack-based buffer overflow in the dokan1.sys driver. An attacker can create a device handle to the system driver and send arbitrary input that will trigger the vulnerability. This vulnerability was introduced in the 1.0.0.5000 version update.
Affected products
- Dokan-Dev Dokany: from 1.0.0.5000 before 1.2.0.1000 — fixed in 1.2.0.1000
How to fix
Upgrade to a fixed version: Dokan-Dev Dokany 1.2.0.1000. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106274
- https://cwe.mitre.org/data/definitions/121.html
- https://github.com/dokan-dev/dokany/releases/tag/v1.2.1.1000
- https://kb.cert.org/vuls/id/741315/
- https://www.exploit-db.com/exploits/46155/
- http://www.securityfocus.com/bid/106274
- https://cwe.mitre.org/data/definitions/121.html
- https://github.com/dokan-dev/dokany/releases/tag/v1.2.1.1000
- https://kb.cert.org/vuls/id/741315/
- https://www.exploit-db.com/exploits/46155/
Get alerted when CVE-2018-5410 or the next vulnerability affects your stack