What’s Vulnerable › Vulnerabilities
CVE-2018-5703
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-01-16 · updated 2026-06-17
- Weakness: CWE-787
Description
The tcp_v6_syn_recv_sock function in net/ipv6/tcp_ipv6.c in the Linux kernel through 4.14.11 allows attackers to cause a denial of service (slab out-of-bounds write) or possibly have unspecified other impact via vectors involving TLS.
Affected products
- Linux kernel: from 4.13 before 4.14.86; from 4.15 before 4.15.8 — fixed in 4.14.86, 4.15.8
How to fix
Upgrade to a fixed version: Linux kernel 4.14.86, 4.15.8. Check the vendor advisory for mitigations.
References
- https://groups.google.com/d/msg/syzkaller-bugs/0PBeVnSzfqQ/5eXAlM46BQAJ
- https://groups.google.com/d/msg/syzkaller-bugs/0PBeVnSzfqQ/5eXAlM46BQAJ
Get alerted when CVE-2018-5703 or the next vulnerability affects your stack