What’s Vulnerable › Vulnerabilities
CVE-2018-5809
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-787
Description
An error within the "LibRaw::parse_exif()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.9 can be exploited to cause a stack-based buffer overflow and subsequently execute arbitrary code.
Affected products
- LibRaw: before 0.18.9 — fixed in 0.18.9
How to fix
Upgrade to a fixed version: LibRaw 0.18.9. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/fd6330292501983ac75fe4162275794b18445bd9
- https://secuniaresearch.flexerasoftware.com/advisories/81800/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-9/
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/fd6330292501983ac75fe4162275794b18445bd9
- https://secuniaresearch.flexerasoftware.com/advisories/81800/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-9/
Get alerted when CVE-2018-5809 or the next vulnerability affects your stack