What’s Vulnerable › Vulnerabilities
CVE-2018-5816
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-07 · updated 2026-06-17
- Weakness: CWE-190
Description
An integer overflow error within the "identify()" function (internal/dcraw_common.cpp) in LibRaw versions prior to 0.18.12 can be exploited to trigger a division by zero via specially crafted NOKIARAW file (Note: This vulnerability is caused due to an incomplete fix of CVE-2018-5804).
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- LibRaw: before 0.18.12 — fixed in 0.18.12
How to fix
Upgrade to a fixed version: LibRaw 0.18.12. Check the vendor advisory for mitigations.
References
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/1d8d1b452e5dc74033ee9f846081a0efb616cc39
- https://secuniaresearch.flexerasoftware.com/advisories/83507/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-14/
- https://usn.ubuntu.com/3838-1/
- https://github.com/LibRaw/LibRaw/blob/master/Changelog.txt
- https://github.com/LibRaw/LibRaw/commit/1d8d1b452e5dc74033ee9f846081a0efb616cc39
- https://secuniaresearch.flexerasoftware.com/advisories/83507/
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-14/
- https://usn.ubuntu.com/3838-1/
Get alerted when CVE-2018-5816 or the next vulnerability affects your stack