What’s Vulnerable › Vulnerabilities
CVE-2018-5819
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-02-20 · updated 2026-06-17
- Weakness: CWE-400
Description
An error within the "parse_sinar_ia()" function (internal/dcraw_common.cpp) within LibRaw versions prior to 0.19.1 can be exploited to exhaust available CPU resources.
Affected products
- Debian Linux: 8.0
- LibRaw: before 0.19.1 — fixed in 0.19.1
How to fix
Upgrade to a fixed version: LibRaw 0.19.1. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2019/03/msg00036.html
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-27/
- https://usn.ubuntu.com/3989-1/
- https://www.libraw.org/news/libraw-0-19-2-release
- https://lists.debian.org/debian-lts-announce/2019/03/msg00036.html
- https://secuniaresearch.flexerasoftware.com/secunia_research/2018-27/
- https://usn.ubuntu.com/3989-1/
- https://www.libraw.org/news/libraw-0-19-2-release
Get alerted when CVE-2018-5819 or the next vulnerability affects your stack