What’s Vulnerable › Vulnerabilities
CVE-2018-5950
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-23 · updated 2026-06-17
- Weakness: CWE-79
Description
Cross-site scripting (XSS) vulnerability in the web UI in Mailman before 2.1.26 allows remote attackers to inject arbitrary web script or HTML via a user-options URL.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- GNU Mailman: before 2.1.26 — fixed in 2.1.26
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6
- RedHat Enterprise Linux Server Eus: 7.4, 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.4, 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: GNU Mailman 2.1.26. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/159761/Mailman-2.1.23-Cross-Site-Scripting.html
- http://www.securityfocus.com/bid/104594
- https://access.redhat.com/errata/RHSA-2018:0504
- https://access.redhat.com/errata/RHSA-2018:0505
- https://bugs.launchpad.net/mailman/+bug/1747209
- https://lists.debian.org/debian-lts-announce/2018/02/msg00007.html
- https://usn.ubuntu.com/3563-1/
- https://www.debian.org/security/2018/dsa-4108
- https://www.mail-archive.com/mailman-users%40python.org/msg70375.html
- http://packetstormsecurity.com/files/159761/Mailman-2.1.23-Cross-Site-Scripting.html
- http://www.securityfocus.com/bid/104594
- https://access.redhat.com/errata/RHSA-2018:0504
Get alerted when CVE-2018-5950 or the next vulnerability affects your stack