What’s Vulnerable › Vulnerabilities

CVE-2018-5968

Description

FasterXML jackson-databind through 2.8.11 and 2.9.x through 2.9.3 allows unauthenticated remote code execution because of an incomplete fix for the CVE-2017-7525 and CVE-2017-17485 deserialization flaws. This is exploitable via two different gadgets that bypass a blacklist.

Affected products

How to fix

Upgrade to a fixed version: FasterXML jackson-databind 2.6.7.3, 2.7.9.2, 2.8.11.1, 2.9.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-5968 or the next vulnerability affects your stack