What’s Vulnerable › Vulnerabilities
CVE-2018-5996
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-31 · updated 2026-06-17
- Weakness: CWE-119
Description
Insufficient exception handling in the method NCompress::NRar3::CDecoder::Code of 7-Zip before 18.00 and p7zip can lead to multiple memory corruptions within the PPMd code, allows remote attackers to cause a denial of service (segmentation fault) or execute arbitrary code via a crafted RAR archive.
Affected products
- 7-Zip: before 18.00 — fixed in 18.00
- 7-Zip P7Zip: before 18.0 — fixed in 18.0
- Debian Linux: 7.0, 8.0, 9.0
How to fix
Upgrade to a fixed version: 7-Zip 18.00; 7-Zip P7Zip 18.0. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1040831
- https://0patch.blogspot.si/2018/02/two-interesting-micropatches-for-7-zip.html
- https://github.com/p7zip-project/p7zip/issues/32
- https://github.com/p7zip-project/p7zip/issues/8
- https://landave.io/2018/01/7-zip-multiple-memory-corruptions-via-rar-and-zip/
- http://www.securitytracker.com/id/1040831
- https://0patch.blogspot.si/2018/02/two-interesting-micropatches-for-7-zip.html
- https://landave.io/2018/01/7-zip-multiple-memory-corruptions-via-rar-and-zip/
Get alerted when CVE-2018-5996 or the next vulnerability affects your stack