What’s Vulnerable › Vulnerabilities
CVE-2018-6015
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-26 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue was discovered in the "Email Subscribers & Newsletters" plugin before 3.4.8 for WordPress. Sending an HTTP POST request to a URI with /?es=export at the end, and adding option=view_all_subscribers in the body, allows downloading of a CSV data file with all subscriber data.
Affected products
- icegram Email Subscribers & Newsletters – Email Marketing, Post Notifications & Newsletter Plugin for WordPress: before 3.4.8 — fixed in 3.4.8
How to fix
Upgrade to a fixed version: icegram Email Subscribers & Newsletters – Email Marketing, Post Notifications & Newsletter Plugin for WordPress 3.4.8. Check the vendor advisory for mitigations.
References
- https://blog.threatpress.com/vulnerability-email-subscribers-plugin/
- https://wordpress.org/plugins/email-subscribers/#developers
- https://www.exploit-db.com/exploits/43872/
- https://blog.threatpress.com/vulnerability-email-subscribers-plugin/
- https://wordpress.org/plugins/email-subscribers/#developers
- https://www.exploit-db.com/exploits/43872/
Get alerted when CVE-2018-6015 or the next vulnerability affects your stack