What’s Vulnerable › Vulnerabilities

CVE-2018-6182

Description

Mahara 16.10 before 16.10.9 and 17.04 before 17.04.7 and 17.10 before 17.10.4 are vulnerable to bad input when TinyMCE is bypassed by POST packages. Therefore, Mahara should not rely on TinyMCE's code stripping alone but also clean input on the server / PHP side as one can create own packets of POST data containing bad content with which to hit the server.

Affected products

How to fix

Upgrade to a fixed version: mahara 16.10.9, 17.04.7, 17.10.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-6182 or the next vulnerability affects your stack