What’s Vulnerable › Vulnerabilities
CVE-2018-6194
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-01-30 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability in admin/partials/wp-splashing-admin-sidebar.php in the Splashing Images plugin (wp-splashing-images) before 2.1.1 for WordPress allows remote attackers to inject arbitrary web script or HTML via the search parameter to wp-admin/upload.php.
Affected products
- Splashing Images Project Splashing Images: before 2.1.1 — fixed in 2.1.1
How to fix
Upgrade to a fixed version: Splashing Images Project Splashing Images 2.1.1. Check the vendor advisory for mitigations.
References
- http://packetstormsecurity.com/files/146109/WordPress-Splashing-Images-2.1-Cross-Site-Scripting-PHP-Object-Injection.html
- http://seclists.org/fulldisclosure/2018/Jan/91
- https://plugins.trac.wordpress.org/changeset/1807349/wp-splashing-images
- https://wpvulndb.com/vulnerabilities/9016
- http://packetstormsecurity.com/files/146109/WordPress-Splashing-Images-2.1-Cross-Site-Scripting-PHP-Object-Injection.html
- http://seclists.org/fulldisclosure/2018/Jan/91
- https://plugins.trac.wordpress.org/changeset/1807349/wp-splashing-images
- https://wpvulndb.com/vulnerabilities/9016
Get alerted when CVE-2018-6194 or the next vulnerability affects your stack