What’s Vulnerable › Vulnerabilities
CVE-2018-6307
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 26.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-19 · updated 2026-06-17
- Weakness: CWE-416
Description
LibVNC before commit ca2a5ac02fbbadd0a21fabba779c1ea69173d10b contains heap use-after-free vulnerability in server code of file transfer extension that can result remote code execution.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04, 18.10
- Debian Linux: 8.0, 9.0
- Libvnc Project Libvncserver: before 0.9.12 — fixed in 0.9.12
How to fix
Upgrade to a fixed version: Libvnc Project Libvncserver 0.9.12. Check the vendor advisory for mitigations.
References
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-026-libvnc-heap-use-after-free/
- https://lists.debian.org/debian-lts-announce/2018/12/msg00017.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
- https://usn.ubuntu.com/3877-1/
- https://www.debian.org/security/2019/dsa-4383
- https://github.com/LibVNC/libvncserver/issues/241
- https://ics-cert.kaspersky.com/advisories/klcert-advisories/2018/12/19/klcert-18-026-libvnc-heap-use-after-free/
- https://lists.debian.org/debian-lts-announce/2018/12/msg00017.html
- https://lists.debian.org/debian-lts-announce/2019/10/msg00042.html
- https://usn.ubuntu.com/3877-1/
- https://www.debian.org/security/2019/dsa-4383
Get alerted when CVE-2018-6307 or the next vulnerability affects your stack