What’s Vulnerable › Vulnerabilities
CVE-2018-6341
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-31 · updated 2026-06-17
- Weakness: CWE-79
Description
React applications which rendered to HTML using the ReactDOMServer API were not escaping user-supplied attribute names at render-time. That lack of escaping could lead to a cross-site scripting vulnerability. This issue affected minor releases 16.0.x, 16.1.x, 16.2.x, 16.3.x, and 16.4.x. It was fixed in 16.0.1, 16.1.2, 16.2.1, 16.3.3, and 16.4.2.
Affected products
- React: from 16.0.0 before 16.0.1; from 16.1.0 before 16.1.2; from 16.2.0 before 16.2.1; from 16.3.0 before 16.3.3; from 16.4.0 before 16.4.2 — fixed in 16.0.1, 16.1.2, 16.2.1, 16.3.3, 16.4.2
How to fix
Upgrade to a fixed version: React 16.0.1, 16.1.2, 16.2.1, 16.3.3. Check the vendor advisory for mitigations.
References
- https://reactjs.org/blog/2018/08/01/react-v-16-4-2.html
- https://twitter.com/reactjs/status/1024745321987887104
- https://reactjs.org/blog/2018/08/01/react-v-16-4-2.html
- https://twitter.com/reactjs/status/1024745321987887104
Get alerted when CVE-2018-6341 or the next vulnerability affects your stack