What’s Vulnerable › Vulnerabilities
CVE-2018-6343
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-31 · updated 2026-06-17
- Weakness: CWE-476
Description
Proxygen fails to validate that a secondary auth manager is set before dereferencing it. That can cause a denial of service issue when parsing a Certificate/CertificateRequest HTTP2 Frame over a fizz (TLS 1.3) transport. This issue affects Proxygen releases starting from v2018.10.29.00 until the fix in v2018.11.19.00.
Affected products
- Facebook proxygen: from 2018.10.29.00 before 2018.11.19.00 — fixed in 2018.11.19.00
How to fix
Upgrade to a fixed version: Facebook proxygen 2018.11.19.00. Check the vendor advisory for mitigations.
References
- https://github.com/facebook/proxygen/commit/0600ebe59c3e82cd012def77ca9ca1918da74a71
- https://github.com/facebook/proxygen/commit/0600ebe59c3e82cd012def77ca9ca1918da74a71
Get alerted when CVE-2018-6343 or the next vulnerability affects your stack