What’s Vulnerable › Vulnerabilities
CVE-2018-6347
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-31 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue in the Proxygen handling of HTTP2 parsing of headers/trailers can lead to a denial-of-service attack. This affects Proxygen prior to v2018.12.31.00.
Affected products
- Facebook Proxygen before 2015-11-09: before 2018.12.31.00 — fixed in 2018.12.31.00
How to fix
Upgrade to a fixed version: Facebook Proxygen before 2015-11-09 2018.12.31.00. Check the vendor advisory for mitigations.
References
- https://github.com/facebook/proxygen/commit/223e0aa6bc7590e86af1e917185a2e0efe160711
- https://github.com/facebook/proxygen/commit/223e0aa6bc7590e86af1e917185a2e0efe160711
Get alerted when CVE-2018-6347 or the next vulnerability affects your stack