What’s Vulnerable › Vulnerabilities
CVE-2018-6511: XSS Vulnerability in Puppet Enterprise Console
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-08 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting vulnerability in Puppet Enterprise Console of Puppet Enterprise allows a user to inject scripts into the Puppet Enterprise Console when using the Puppet Enterprise Console. Affected releases are Puppet Puppet Enterprise: 2017.3.x versions prior to 2017.3.6.
Affected products
- Puppet Enterprise: before 2017.3.6 — fixed in 2017.3.6
How to fix
Upgrade to a fixed version: Puppet Enterprise 2017.3.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-6511 or the next vulnerability affects your stack