What’s Vulnerable › Vulnerabilities

CVE-2018-6513

Description

Puppet Enterprise 2016.4.x prior to 2016.4.12, Puppet Enterprise 2017.3.x prior to 2017.3.7, Puppet Enterprise 2018.1.x prior to 2018.1.1, Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, and Puppet Agent 5.5.x prior to 5.5.2, were vulnerable to an attack where an unprivileged user on Windows agents could write custom facts that can escalate privileges on the next puppet run. This was possible through the loading of shared libraries from untrusted paths.

Affected products

How to fix

Upgrade to a fixed version: Puppet Agent 1.10.13, 5.3.7, 5.5.2; Puppet Enterprise 2016.4.12, 2017.3.7, 2018.1.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-6513 or the next vulnerability affects your stack