What’s Vulnerable › Vulnerabilities

CVE-2018-6514

Description

In Puppet Agent 1.10.x prior to 1.10.13, Puppet Agent 5.3.x prior to 5.3.7, Puppet Agent 5.5.x prior to 5.5.2, Facter on Windows is vulnerable to a DLL preloading attack, which could lead to a privilege escalation.

Affected products

How to fix

Upgrade to a fixed version: Puppet Agent 1.10.13, 5.3.7, 5.5.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-6514 or the next vulnerability affects your stack