What’s Vulnerable › Vulnerabilities

CVE-2018-6516

Description

On Windows only, with a specifically crafted configuration file an attacker could get Puppet PE client tools (aka pe-client-tools) 16.4.x prior to 16.4.6, 17.3.x prior to 17.3.6, and 18.1.x prior to 18.1.2 to load arbitrary code with privilege escalation.

Affected products

How to fix

Upgrade to a fixed version: Puppet pe-client-tools 16.4.6, 17.3.6, 18.1.2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-6516 or the next vulnerability affects your stack