What’s Vulnerable › Vulnerabilities
CVE-2018-6521
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-02 · updated 2026-06-17
Description
The sqlauth module in SimpleSAMLphp before 1.15.2 relies on the MySQL utf8 charset, which truncates queries upon encountering four-byte characters. There might be a scenario in which this allows remote attackers to bypass intended access restrictions.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- simplesamlphp: before 1.15.2 — fixed in 1.15.2
How to fix
Upgrade to a fixed version: simplesamlphp 1.15.2. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2018/02/msg00008.html
- https://simplesamlphp.org/security/201801-03
- https://www.debian.org/security/2018/dsa-4127
- https://lists.debian.org/debian-lts-announce/2018/02/msg00008.html
- https://simplesamlphp.org/security/201801-03
- https://www.debian.org/security/2018/dsa-4127
Get alerted when CVE-2018-6521 or the next vulnerability affects your stack