What’s Vulnerable › Vulnerabilities
CVE-2018-6555
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-04 · updated 2026-06-17
- Weakness: CWE-416
Description
The irda_setsockopt function in net/irda/af_irda.c and later in drivers/staging/irda/net/af_irda.c in the Linux kernel before 4.17 allows local users to cause a denial of service (ias_object use-after-free and system crash) or possibly have unspecified other impact via an AF_IRDA socket.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- Linux kernel: before 4.17 — fixed in 4.17
How to fix
Upgrade to a fixed version: Linux kernel 4.17. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105304
- https://lists.debian.org/debian-lts-announce/2018/10/msg00003.html
- https://usn.ubuntu.com/3775-1/
- https://usn.ubuntu.com/3775-2/
- https://usn.ubuntu.com/3776-1/
- https://usn.ubuntu.com/3776-2/
- https://usn.ubuntu.com/3777-1/
- https://usn.ubuntu.com/3777-2/
- https://usn.ubuntu.com/3777-3/
- https://www.debian.org/security/2018/dsa-4308
- https://www.spinics.net/lists/stable/msg255031.html
- https://www.spinics.net/lists/stable/msg255035.html
Get alerted when CVE-2018-6555 or the next vulnerability affects your stack