What’s Vulnerable › Vulnerabilities
CVE-2018-6556: The lxc-user-nic component of LXC allows unprivileged users to open arbitrary files
- Severity: low (CVSS 3.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-10 · updated 2026-06-17
- Weakness: CWE-417
Description
lxc-user-nic when asked to delete a network interface will unconditionally open a user provided path. This code path may be used by an unprivileged user to check for the existence of a path which they wouldn't otherwise be able to reach. It may also be used to trigger side effects by causing a (read-only) open of special kernel files (ptmx, proc, sys). Affected releases are LXC: 2.0 versions above and including 2.0.9; 3.0 versions above and including 3.0.0, prior to 3.0.2.
Affected products
- Canonical Ubuntu Linux: 18.04
- lxc: from 2.0.0 through 2.0.9; from 3.0.0 before 3.0.2 — fixed in 3.0.2
- openSUSE Leap: 15.0
- SUSE CaaS Platform 4.5: 1.0, 2.0
- SUSE Openstack Cloud: 6
- SUSE Linux Enterprise: 11-sp3, 11-sp4
How to fix
Upgrade to a fixed version: lxc 3.0.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00074.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00091.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00073.html
- https://bugs.launchpad.net/ubuntu/+source/lxc/+bug/1783591
- https://bugzilla.suse.com/show_bug.cgi?id=988348
- https://security.gentoo.org/glsa/201808-02
- https://usn.ubuntu.com/usn/usn-3730-1
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00074.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00076.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00091.html
- http://lists.opensuse.org/opensuse-security-announce/2019-05/msg00073.html
Get alerted when CVE-2018-6556 or the next vulnerability affects your stack