What’s Vulnerable › Vulnerabilities
CVE-2018-6560
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-02 · updated 2026-06-17
- Weakness: CWE-436
Description
In dbus-proxy/flatpak-proxy.c in Flatpak before 0.8.9, and 0.9.x and 0.10.x before 0.10.3, crafted D-Bus messages to the host can be used to break out of the sandbox, because whitespace handling in the proxy is not identical to whitespace handling in the daemon.
Affected products
- flatpak: before 0.8.9; from 0.9.1 through 0.9.99; from 0.10.0 before 0.10.3 — fixed in 0.10.3, 0.8.9
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: flatpak 0.10.3, 0.8.9. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:2766
- https://github.com/flatpak/flatpak/commit/52346bf187b5a7f1c0fe9075b328b7ad6abe78f6
- https://github.com/flatpak/flatpak/releases/tag/0.10.3
- https://github.com/flatpak/flatpak/releases/tag/0.8.9
- https://access.redhat.com/errata/RHSA-2018:2766
- https://github.com/flatpak/flatpak/commit/52346bf187b5a7f1c0fe9075b328b7ad6abe78f6
- https://github.com/flatpak/flatpak/releases/tag/0.10.3
- https://github.com/flatpak/flatpak/releases/tag/0.8.9
Get alerted when CVE-2018-6560 or the next vulnerability affects your stack