What’s Vulnerable › Vulnerabilities
CVE-2018-6611
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-04 · updated 2026-06-17
- Weakness: CWE-125
Description
soundlib/Load_stp.cpp in OpenMPT through 1.27.04.00, and libopenmpt before 0.3.6, has an out-of-bounds read via a malformed STP file.
Affected products
- Openmpt Libopenmpt: before 0.3.6 — fixed in 0.3.6
- Openmpt: through 1.27.04.00
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.3.6. Check the vendor advisory for mitigations.
References
- https://github.com/OpenMPT/openmpt/commit/b60b322cf9f0ffa624018f1bb9783edf0dc908c3
- https://lib.openmpt.org/libopenmpt/2018/02/03/security-update-0.3.6/
- https://github.com/OpenMPT/openmpt/commit/b60b322cf9f0ffa624018f1bb9783edf0dc908c3
- https://lib.openmpt.org/libopenmpt/2018/02/03/security-update-0.3.6/
Get alerted when CVE-2018-6611 or the next vulnerability affects your stack