What’s Vulnerable › Vulnerabilities
CVE-2018-6789: Exim Buffer Overflow Vulnerability
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: yes — in CISA KEV since 2021-11-03
- EPSS: 82.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-08 · updated 2026-06-17
- Weakness: CWE-120
Description
An issue was discovered in the base64d function in the SMTP listener in Exim before 4.90.1. By sending a handcrafted message, a buffer overflow may happen. This can be used to execute code remotely.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- Exim: before 4.90.1 — fixed in 4.90.1
How to fix
Upgrade to a fixed version: Exim 4.90.1. Check the vendor advisory for mitigations.
References
- http://openwall.com/lists/oss-security/2018/02/10/2
- http://packetstormsecurity.com/files/162959/Exim-base64d-Buffer-Overflow.html
- http://www.openwall.com/lists/oss-security/2018/02/07/2
- http://www.securityfocus.com/bid/103049
- http://www.securitytracker.com/id/1040461
- https://devco.re/blog/2018/03/06/exim-off-by-one-RCE-exploiting-CVE-2018-6789-en/
- https://exim.org/static/doc/security/CVE-2018-6789.txt
- https://git.exim.org/exim.git/commit/cf3cd306062a08969c41a1cdd32c6855f1abecf1
- https://lists.debian.org/debian-lts-announce/2018/02/msg00009.html
- https://usn.ubuntu.com/3565-1/
- https://www.debian.org/security/2018/dsa-4110
- https://www.exploit-db.com/exploits/44571/
Get alerted when CVE-2018-6789 or the next vulnerability affects your stack