What’s Vulnerable › Vulnerabilities
CVE-2018-6834
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-08 · updated 2026-06-17
- Weakness: CWE-79
Description
static/js/pad_utils.js in Etherpad Lite before v1.6.3 has XSS via window.location.href.
Affected products
- Etherpad Lite: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: Etherpad Lite 1.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/ether/etherpad-lite/commit/a03422b09468cdd5f192b05643311c705447588b
- https://github.com/ether/etherpad-lite/releases/tag/1.6.3
- https://github.com/ether/etherpad-lite/commit/a03422b09468cdd5f192b05643311c705447588b
- https://github.com/ether/etherpad-lite/releases/tag/1.6.3
Get alerted when CVE-2018-6834 or the next vulnerability affects your stack