What’s Vulnerable › Vulnerabilities
CVE-2018-6835
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-08 · updated 2026-06-17
- Weakness: CWE-20
Description
node/hooks/express/apicalls.js in Etherpad Lite before v1.6.3 mishandles JSONP, which allows remote attackers to bypass intended access restrictions.
Affected products
- etherpad-lite: before 1.6.3 — fixed in 1.6.3
How to fix
Upgrade to a fixed version: etherpad-lite 1.6.3. Check the vendor advisory for mitigations.
References
- https://github.com/ether/etherpad-lite/commit/626e58cc5af1db3691b41fca7b06c28ea43141b1
- https://github.com/ether/etherpad-lite/releases/tag/1.6.3
- https://github.com/ether/etherpad-lite/commit/626e58cc5af1db3691b41fca7b06c28ea43141b1
- https://github.com/ether/etherpad-lite/releases/tag/1.6.3
Get alerted when CVE-2018-6835 or the next vulnerability affects your stack