What’s Vulnerable › Vulnerabilities
CVE-2018-6871
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 22.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-02-09 · updated 2026-06-17
Description
LibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary files via =WEBSERVICE calls in a document, which use the COM.MICROSOFT.WEBSERVICE function.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10
- Debian Linux: 9.0
- The Document Foundation LibreOffice: before 5.4.5; 6.0.0, 6.0.0-alpha1, 6.0.0-beta1, 6.0.0-beta2 — fixed in 5.4.5
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.4, 7.6
- RedHat Enterprise Linux Server Eus: 7.4, 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.4, 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: The Document Foundation LibreOffice 5.4.5. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:0418
- https://access.redhat.com/errata/RHSA-2018:0517
- https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-4-5&id=a916fc0c0e0e8b10cb4158fa0fa173fe205d434a
- https://github.com/jollheef/libreoffice-remote-arbitrary-file-disclosure
- https://usn.ubuntu.com/3579-1/
- https://www.debian.org/security/2018/dsa-4111
- https://www.exploit-db.com/exploits/44022/
- https://www.libreoffice.org/about-us/security/advisories/cve-2018-1055/
- https://access.redhat.com/errata/RHSA-2018:0418
- https://access.redhat.com/errata/RHSA-2018:0517
- https://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-5-4-5&id=a916fc0c0e0e8b10cb4158fa0fa173fe205d434a
- https://github.com/jollheef/libreoffice-remote-arbitrary-file-disclosure
Get alerted when CVE-2018-6871 or the next vulnerability affects your stack