What’s Vulnerable › Vulnerabilities
CVE-2018-6905
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-04-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The page module in TYPO3 before 8.7.11, and 9.1.0, has XSS via $GLOBALS['TYPO3_CONF_VARS']['SYS']['sitename'], as demonstrated by an admin entering a crafted site name during the installation process.
Affected products
- typo3: before 8.7.11; from 9.0.0 before 9.1.0 — fixed in 8.7.11, 9.1.0
How to fix
Upgrade to a fixed version: typo3 8.7.11, 9.1.0. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1040755
- https://forge.typo3.org/issues/84191
- https://github.com/pradeepjairamani/TYPO3-XSS-POC
- http://www.securitytracker.com/id/1040755
- https://forge.typo3.org/issues/84191
- https://github.com/pradeepjairamani/TYPO3-XSS-POC
Get alerted when CVE-2018-6905 or the next vulnerability affects your stack