What’s Vulnerable › Vulnerabilities
CVE-2018-6913
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-17 · updated 2026-06-17
- Weakness: CWE-787
Description
Heap-based buffer overflow in the pack function in Perl before 5.26.2 allows context-dependent attackers to execute arbitrary code via a large item count.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0, 9.0
- perl: before 5.26.2 — fixed in 5.26.2
How to fix
Upgrade to a fixed version: perl 5.26.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103953
- http://www.securitytracker.com/id/1040681
- https://lists.debian.org/debian-lts-announce/2018/04/msg00009.html
- https://rt.perl.org/Public/Bug/Display.html?id=131844
- https://security.gentoo.org/glsa/201909-01
- https://usn.ubuntu.com/3625-1/
- https://usn.ubuntu.com/3625-2/
- https://www.debian.org/security/2018/dsa-4172
- https://www.oracle.com/security-alerts/cpujul2020.html
- http://www.securityfocus.com/bid/103953
- http://www.securitytracker.com/id/1040681
- https://lists.debian.org/debian-lts-announce/2018/04/msg00009.html
Get alerted when CVE-2018-6913 or the next vulnerability affects your stack