What’s Vulnerable › Vulnerabilities
CVE-2018-6916
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-09 · updated 2026-06-17
- Weakness: CWE-416
Description
In FreeBSD before 11.1-STABLE, 11.1-RELEASE-p7, 10.4-STABLE, 10.4-RELEASE-p7, and 10.3-RELEASE-p28, the kernel does not properly validate IPsec packets coming from a trusted host. Additionally, a use-after-free vulnerability exists in the IPsec AH handling code. This issue could cause a system crash or other unpredictable results.
Affected products
- FreeBSD: from 11.0 before 11.1; 10.3-p28, 10.4, 10.4-p7 — fixed in 11.1
How to fix
Upgrade to a fixed version: FreeBSD 11.1. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1040460
- https://www.freebsd.org/security/advisories/FreeBSD-SA-18:01.ipsec.asc
- http://www.securitytracker.com/id/1040460
- https://www.freebsd.org/security/advisories/FreeBSD-SA-18:01.ipsec.asc
Get alerted when CVE-2018-6916 or the next vulnerability affects your stack