What’s Vulnerable › Vulnerabilities
CVE-2018-6917
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-04 · updated 2026-06-17
- Weakness: CWE-190
Description
In FreeBSD before 11.1-STABLE, 11.1-RELEASE-p9, 10.4-STABLE, 10.4-RELEASE-p8 and 10.3-RELEASE-p28, insufficient validation of user-provided font parameters can result in an integer overflow, leading to the use of arbitrary kernel memory as glyph data. Unprivileged users may be able to access privileged kernel data.
Affected products
- FreeBSD: from 10.0 before 10.4; from 11.0 before 11.1 — fixed in 10.4, 11.1
How to fix
Upgrade to a fixed version: FreeBSD 10.4, 11.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/103668
- http://www.securitytracker.com/id/1040629
- https://security.FreeBSD.org/advisories/FreeBSD-SA-18:04.vt.asc
- http://www.securityfocus.com/bid/103668
- http://www.securitytracker.com/id/1040629
- https://security.FreeBSD.org/advisories/FreeBSD-SA-18:04.vt.asc
Get alerted when CVE-2018-6917 or the next vulnerability affects your stack