What’s Vulnerable › Vulnerabilities
CVE-2018-6924
- Severity: high (CVSS 7.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-12 · updated 2026-06-17
- Weakness: CWE-20
Description
In FreeBSD before 11.1-STABLE, 11.2-RELEASE-p3, 11.1-RELEASE-p14, 10.4-STABLE, and 10.4-RELEASE-p12, insufficient validation in the ELF header parser could allow a malicious ELF binary to cause a kernel crash or disclose kernel memory.
Affected products
- FreeBSD: from 11.0 before 11.1; 10.4, 11.2 — fixed in 11.1
How to fix
Upgrade to a fixed version: FreeBSD 11.1. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1041646
- https://security.freebsd.org/advisories/FreeBSD-SA-18:12.elf.asc
- http://www.securitytracker.com/id/1041646
- https://security.freebsd.org/advisories/FreeBSD-SA-18:12.elf.asc
Get alerted when CVE-2018-6924 or the next vulnerability affects your stack