What’s Vulnerable › Vulnerabilities
CVE-2018-6927
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-02-12 · updated 2026-06-17
- Weakness: CWE-190
Description
The futex_requeue function in kernel/futex.c in the Linux kernel before 4.14.15 might allow attackers to cause a denial of service (integer overflow) or possibly have unspecified other impact by triggering a negative wake or requeue value.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10
- Debian Linux: 7.0, 8.0
- Linux kernel: before 4.14.15 — fixed in 4.14.15
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
- RedHat Virtualization Host: 4.0
How to fix
Upgrade to a fixed version: Linux kernel 4.14.15. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=fbe0e839d1e22d88810f3ee3e2f1479be4c0aa4a
- http://www.securityfocus.com/bid/103023
- https://access.redhat.com/errata/RHSA-2018:0654
- https://access.redhat.com/errata/RHSA-2018:0676
- https://access.redhat.com/errata/RHSA-2018:1062
- https://github.com/torvalds/linux/commit/fbe0e839d1e22d88810f3ee3e2f1479be4c0aa4a
- https://lists.debian.org/debian-lts-announce/2018/05/msg00000.html
- https://usn.ubuntu.com/3619-1/
- https://usn.ubuntu.com/3619-2/
- https://usn.ubuntu.com/3697-1/
- https://usn.ubuntu.com/3697-2/
- https://usn.ubuntu.com/3698-1/
Get alerted when CVE-2018-6927 or the next vulnerability affects your stack