What’s Vulnerable › Vulnerabilities
CVE-2018-6964
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-29 · updated 2026-06-17
Description
VMware Horizon Client for Linux (4.x before 4.8.0 and prior) contains a local privilege escalation vulnerability due to insecure usage of SUID binary. Successful exploitation of this issue may allow unprivileged users to escalate their privileges to root on a Linux machine where Horizon Client is installed.
Affected products
- VMware Horizon Server: from 4.0.0 before 4.8.0 — fixed in 4.8.0
How to fix
Upgrade to a fixed version: VMware Horizon Server 4.8.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104315
- http://www.securitytracker.com/id/1040989
- https://www.vmware.com/security/advisories/VMSA-2018-0014.html
- http://www.securityfocus.com/bid/104315
- http://www.securitytracker.com/id/1040989
- https://www.vmware.com/security/advisories/VMSA-2018-0014.html
Get alerted when CVE-2018-6964 or the next vulnerability affects your stack