What’s Vulnerable › Vulnerabilities
CVE-2018-6969
- Severity: high (CVSS 7.0 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-13 · updated 2026-06-17
- Weakness: CWE-125
Description
VMware Tools (10.x and prior before 10.3.0) contains an out-of-bounds read vulnerability in HGFS. Successful exploitation of this issue may lead to information disclosure or may allow attackers to escalate their privileges on the guest VMs. In order to be able to exploit this issue, file sharing must be enabled.
Affected products
- VMware Tools: before 10.3.0 — fixed in 10.3.0
How to fix
Upgrade to a fixed version: VMware Tools 10.3.0. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104737
- http://www.securitytracker.com/id/1041291
- https://www.vmware.com/security/advisories/VMSA-2018-0017.html
- http://www.securityfocus.com/bid/104737
- http://www.securitytracker.com/id/1041291
- https://www.vmware.com/security/advisories/VMSA-2018-0017.html
Get alerted when CVE-2018-6969 or the next vulnerability affects your stack