What’s Vulnerable › Vulnerabilities

CVE-2018-6970

Description

VMware Horizon 6 (6.x.x before 6.2.7), Horizon 7 (7.x.x before 7.5.1), and Horizon Client (4.x.x and prior before 4.8.1) contain an out-of-bounds read vulnerability in the Message Framework library. Successfully exploiting this issue may allow a less-privileged user to leak information from a privileged process running on a system where Horizon Connection Server, Horizon Agent or Horizon Client are installed. Note: This issue doesn't apply to Horizon 6, 7 Agents installed on Linux systems or Horizon Clients installed on non-Windows systems.

Affected products

How to fix

Upgrade to a fixed version: VMware Horizon Server 4.8.1; VMware Horizon View 6.2.7, 7.5.1. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-6970 or the next vulnerability affects your stack