What’s Vulnerable › Vulnerabilities
CVE-2018-6978
- Severity: medium (CVSS 6.7 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-12-18 · updated 2026-06-17
- Weakness: CWE-732
Description
vRealize Operations (7.x before 7.0.0.11287810, 6.7.x before 6.7.0.11286837 and 6.6.x before 6.6.1.11286876) contains a local privilege escalation vulnerability due to improper permissions of support scripts. Admin user of the vROps application with shell access may exploit this issue to elevate the privileges to root on a vROps machine. Note: the admin user (non-sudoer) should not be confused with root of the vROps machine.
Affected products
- VMware vRealize Operations: from 6.6.0 before 6.6.1.11286876; from 6.7.0 before 6.7.0.11286837; from 7.0.0 before 7.0.0.11287810 — fixed in 6.6.1.11286876, 6.7.0.11286837, 7.0.0.11287810
How to fix
Upgrade to a fixed version: VMware vRealize Operations 6.6.1.11286876, 6.7.0.11286837, 7.0.0.11287810. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106242
- https://www.vmware.com/security/advisories/VMSA-2018-0031.html
- http://www.securityfocus.com/bid/106242
- https://www.vmware.com/security/advisories/VMSA-2018-0031.html
Get alerted when CVE-2018-6978 or the next vulnerability affects your stack