What’s Vulnerable › Vulnerabilities
CVE-2018-6979
- Severity: high (CVSS 7.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-05 · updated 2026-06-17
Description
The VMware Workspace ONE Unified Endpoint Management Console (A/W Console) 9.7.x prior to 9.7.0.3, 9.6.x prior to 9.6.0.7, 9.5.x prior to 9.5.0.16, 9.4.x prior to 9.4.0.22, 9.3.x prior to 9.3.0.25, 9.2.x prior to 9.2.3.27, and 9.1.x prior to 9.1.5.6 contains a SAML authentication bypass vulnerability which can be leveraged during device enrollment. This vulnerability may allow for a malicious actor to impersonate an authorized SAML session if certificate-based authentication is enabled. This vulnerability is also relevant if certificate-based authentication is not enabled, but the outcome of exploitation is limited to an information disclosure (Important Severity) in those cases.
Affected products
- VMware Airwatch Console: from 9.1.0.0 before 9.1.5.6; from 9.2.0.0 before 9.2.3.27; from 9.3.0.0 before 9.3.0.25; from 9.4.0.0 before 9.4.0.22; from 9.5.0.0 before 9.5.0.16; from 9.6.0.0 before 9.6.0.7 — fixed in 9.1.5.6, 9.2.3.27, 9.3.0.25, 9.4.0.22, 9.5.0.16, 9.6.0.7
- VMware Airwatch Console: from 9.7.x prior through 9.7.0.8; from 9.6.x prior through 9.6.0.8; from 9.5.x prior through 9.5.0.17; from 9.4.x prior through 9.4.0.23; from 9.3.x prior through 9.3.0.25; from 9.2.x prior through 9.2.3.28
How to fix
Upgrade to a fixed version: VMware Airwatch Console 9.1.5.6, 9.2.3.27, 9.3.0.25, 9.4.0.22. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1041808
- https://www.vmware.com/security/advisories/VMSA-2018-0024.html
- http://www.securitytracker.com/id/1041808
- https://www.vmware.com/security/advisories/VMSA-2018-0024.html
Get alerted when CVE-2018-6979 or the next vulnerability affects your stack