What’s Vulnerable › Vulnerabilities
CVE-2018-7033
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-03-15 · updated 2026-06-17
- Weakness: CWE-89
Description
SchedMD Slurm before 17.02.10 and 17.11.x before 17.11.5 allows SQL Injection attacks against SlurmDBD.
Affected products
- Debian Linux: 7.0, 8.0, 9.0
- SchedMD Slurm: before 17.02.10.0; from 17.11.0.0 before 17.11.5.0; 17.11.0.0-pre1, 17.11.0.0-pre2, 17.11.0.0-rc1, 17.11.0.0-rc2, 17.11.0.0-rc3 — fixed in 17.02.10.0, 17.11.5.0
How to fix
Upgrade to a fixed version: SchedMD Slurm 17.02.10.0, 17.11.5.0. Check the vendor advisory for mitigations.
References
- https://lists.debian.org/debian-lts-announce/2018/04/msg00032.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00029.html
- https://lists.schedmd.com/pipermail/slurm-announce/2018/000006.html
- https://www.debian.org/security/2018/dsa-4254
- https://www.schedmd.com/news.php?id=201
- https://lists.debian.org/debian-lts-announce/2018/04/msg00032.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00029.html
- https://lists.schedmd.com/pipermail/slurm-announce/2018/000006.html
- https://www.debian.org/security/2018/dsa-4254
- https://www.schedmd.com/news.php?id=201
Get alerted when CVE-2018-7033 or the next vulnerability affects your stack