What’s Vulnerable › Vulnerabilities
CVE-2018-7082
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-05-10 · updated 2026-06-17
- Weakness: CWE-78
Description
A command injection vulnerability is present in Aruba Instant that permits an authenticated administrative user to execute arbitrary commands on the underlying operating system. A malicious administrator could use this ability to install backdoors or change system configuration in a way that would not be logged. Workaround: None. Resolution: Fixed in Aruba Instant 4.2.4.12, 6.5.4.11, 8.3.0.6, and 8.4.0.0
Affected products
- Arubanetworks Aruba Instant: from 4.0 before 4.2.4.12; from 6.5.0 before 6.5.4.11; from 8.3.0.0 before 8.3.0.6; from 8.4.0 before 8.4.0.1 — fixed in 4.2.4.12, 6.5.4.11, 8.3.0.6, 8.4.0.1
- Siemens Scalance W1750D Firmware: before 8.4.0.1 — fixed in 8.4.0.1
How to fix
Upgrade to a fixed version: Arubanetworks Aruba Instant 4.2.4.12, 6.5.4.11, 8.3.0.6, 8.4.0.1; Siemens Scalance W1750D Firmware 8.4.0.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/108374
- https://cert-portal.siemens.com/productcert/pdf/ssa-549547.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2019-001.txt
- http://www.securityfocus.com/bid/108374
- https://cert-portal.siemens.com/productcert/pdf/ssa-549547.pdf
- https://www.arubanetworks.com/assets/alert/ARUBA-PSA-2019-001.txt
Get alerted when CVE-2018-7082 or the next vulnerability affects your stack