What’s Vulnerable › Vulnerabilities
CVE-2018-7161
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-13 · updated 2026-10-08
- Weakness: CWE-20
Description
All versions of Node.js 8.x, 9.x, and 10.x are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node server providing an http2 server to crash. This can be accomplished by interacting with the http2 server in a manner that triggers a cleanup bug where objects are used in native code after they are no longer available. This has been addressed by updating the http2 implementation.
Affected products
- Node.js: from 8.0.0 through 8.8.1; from 8.9.0 before 8.11.3; from 9.0.0 before 9.11.2; from 10.0.0 before 10.4.1 — fixed in 10.4.1, 8.11.3, 9.11.2
How to fix
Upgrade to a fixed version: Node.js 10.4.1, 8.11.3, 9.11.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106363
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
- http://www.securityfocus.com/bid/106363
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
Get alerted when CVE-2018-7161 or the next vulnerability affects your stack