What’s Vulnerable › Vulnerabilities
CVE-2018-7162
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 6.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-13 · updated 2026-10-08
- Weakness: CWE-20
Description
All versions of Node.js 9.x and 10.x are vulnerable and the severity is HIGH. An attacker can cause a denial of service (DoS) by causing a node process which provides an http server supporting TLS server to crash. This can be accomplished by sending duplicate/unexpected messages during the handshake. This vulnerability has been addressed by updating the TLS implementation.
Affected products
- Node.js: from 9.0.0 before 9.11.2; from 10.0.0 before 10.4.1 — fixed in 10.4.1, 9.11.2
How to fix
Upgrade to a fixed version: Node.js 10.4.1, 9.11.2. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104468
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
- http://www.securityfocus.com/bid/104468
- https://nodejs.org/en/blog/vulnerability/june-2018-security-releases/
- https://security.gentoo.org/glsa/202003-48
Get alerted when CVE-2018-7162 or the next vulnerability affects your stack